Did You Know That 53% of WordPress Sites Run On an Unsafe PHP Version?

You now know that the security of your WordPress site is very important. But how safe is your WordPress site now? A recent research by Savvii, based on WordPress.org‘s data, reveals that more than half (53%) of WordPress sites run on an unsafe PHP version.

Unsafe PHP version

When a WordPress site runs on an unsafe PHP version, it means running a version of PHP that does not release any security releases. The security of that version can no longer be guaranteed, and this makes this website highly vulnerable to cyber criminals. Currently, only versions 5.6, 7.0 and 7.1 are supported. In other words, if you do not use PHP 5.6, 7.0 or 7.1, you belong to the 53% of WordPress sites running on an unsafe PHP version.

Php versions

Overview of the PHP versions where WordPress sites run

It is actually quite remarkable that so many WordPress websites run on an old PHP version. Certainly, considering that it is known in advance of when a particular version is supported. Of the most recent versions of PHP, these data are already fixed. In many cases it is because it is not clear who now has the responsibility to upgrade to a safer version. Is that the owner of the website, the developer of the website, or the hosting party?

“As a hosting company, we are deliberately choosing not to allow unsafe PHP versions,”

says Alexander van Steen, Technical Manager at Savvii Managed WordPress Hosting.

“All our customers have PHP version 5.6 or higher. We also actively inform our customers about the benefits of PHP 7.x and enable them to easily switch versions. 50% of the websites on our servers are already running on PHP 7.x. That gives a very different image than the global statistics of WordPress sites, only 9%. “

Many website owners have limited technical knowledge; Some do not even know what PHP is. You can not really bother them if their site runs on an unsafe PHP version. In any case, a developer should be upgrading if the hosting party does not take the initiative to upgrade.

Performance

Upgrading an outdated PHP version is not only important for website security, but also for performance. PHP 7.x is 2-3 times as fast as PHP 5.6. And as you probably know, count every second. A faster WordPress website ensures more satisfaction among your visitors, a better reputation, a lower bounce rate, more conversion and a better ranking in Google – which also leads to more visitors.
How about the security of your WordPress site?

Do you doubt the safety? WP Manual can help you with secure hosting! Feel free to contact us for more information. We will be happy to help you safely protect your website!

You may also like...